Вопрос по информатике:
Дано: массив целых чисел A[N].Проверьте, есть ли в нем отрицательные элементы.Если есть, найдите наибольшее i, при котором A[i]<0, иначе выведите сообщение. Напишите программу для Паскаль или лазарус
- 01.06.2018 12:47
- Информатика
- remove_red_eye 3095
- thumb_up 25
Ответы и объяснения 1
Program gt;
var a:array[1..1000]of integer;
i,n,l:integer;
begin
read(n);
l:=0;
for i:=1 to n do
begin
read(a[i]);
if(a[i]<0)then l:=i;
end;
if(l=0)then writeln('НЕТ ОТРИЦА... В массиве')else writeln(l);
end.
- 02.06.2018 19:44
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.