Вопрос по информатике:
Помогите пожалуйста)))
Составьте программу, которая формируют массив из шестнадцати случайных целых чисел от -20 до 20 и:
а) находит элементы с нулевыми значениями;
б) находит индексы четных элементов;
- 09.10.2017 13:42
- Информатика
- remove_red_eye 1517
- thumb_up 32
Ответы и объяснения 1
var
i: integer;
a: array [1..16] of integer;
begin
randomize;
writeln('Массив: ');
for i := 1 to 16 do
begin
a[i] := random(41) - 20;
write(a[i]:5);
end;
writeln;
writeln('Нулевые элементы: ');
for i := 1 to 16 do
if A[i] = 0 then write(i:5);
writeln;
writeln('Четные элементы: ');
for i := 1 to 16 do
if A[i] mod 2 = 0 then write(i:5);
end.
- 01.01.1970 00:00
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.