Вопрос по информатике:
Составьте программу вычисления произведения простых делителей натурального числа N.
- 19.06.2018 19:08
- Информатика
- remove_red_eye 12876
- thumb_up 33
Ответы и объяснения 1
var
x,i,n: integer;
begin
x:=1;
write('Введите натуральное число: ');
read(n);
write('Простые делители числа ',n,': ');
for i:= 1 to n do
if n mod i = 0 then
begin
write(i:4);
x:=x*i;
end;
writeln;
writeln('Их произведение: ',x);
end.
- 20.06.2018 20:57
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.