Вопрос по информатике:
Дано
число k (0 < k < 11) и матрица размера 4 x 10. Найти сумму и произведение
элементов k-го столбца данной матрицы.
Помогите пожалуйста, нужно написать программу в Паскале
- 21.05.2018 18:29
- Информатика
- remove_red_eye 5826
- thumb_up 7
Ответы и объяснения 1
var
j,i,k,sum,proizv: integer;
A: array [1..4,1..10] of integer;
begin
proizv:=1;
randomize;
writeln('Матрица: ');
for i:=1 to 4 do
for j:=1 to 10 do
A[i,j]:=random(21)-10;
for i:=1 to 4 do
begin
for j:=1 to 10 do
write(A[i,j]:5);
writeln;
writeln;
end;
writeln('Введите К: ');
read(k);
for i:=1 to 4 do
begin
sum:=sum+A[i,k];
proizv:=proizv*A[i,k];
end;
writeln('Cумма чисел ',k,'-ого столбца: ',sum);
writeln('Произведение чисел ',k,'-ого столбца: ',proizv);
end.
- 22.05.2018 23:55
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.