Вопрос по информатике:
Написать программу для сложения А и В в троичной системе счисления.
Числа А и В хранятся в первой строке входного файла Exemp.in их сумма в троичной системе-в выходном файле Exemp5.out
- 01.09.2017 08:32
- Информатика
- remove_red_eye 10230
- thumb_up 37
Ответы и объяснения 1
Program chik;
var a,b,q,s1,s2,s:longint;
begin
read(a,b);
s1:=0;
while a>0 do
begin
q:=a mod 3;
a:=a div 3;
s1:=s1*10+q;
end;
s2:=0;
while b>0 do
begin
q:=b mod 3;
b:=b div 3;
s2:=s2*10+q;
end;
s:=s1+s2;
writeln(s);
end.
- 02.09.2017 06:05
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.