Вопрос по информатике:
Найти
НОД(M, N, K) – наибольший
общий делитель трех чисел: M,
N и K. Числа M, N
и K хранятся в первой строке входного
файла Evclid.in, а НОД этих чисел
сохранить в выходном файле Evclid.out.
- 19.03.2017 13:29
- Информатика
- remove_red_eye 8667
- thumb_up 12
Ответы и объяснения 1
Program nod1;
const InFile = 'Evclid.in';
OutFile = 'Evclid.out';
var m, n, k, nod, i, max: integer;
begin
assign(input, infile);
reset(InPut);
Read(InPut, m); Read(InPut, n); Read(InPut, K);
Close(inPut);
nod:= 1;
if m >= n then
max:= m
else max:= n;
if k > max then
max:= k;
for i:= 1 to max do
if (m mod i = 0) and (n mod i = 0) and (k mod i = 0) and (i > nod) then
nod:= i;
assign(OutPut, OutFile);
ReWrite(OutPut);
Write(OutPut, nod);
Close(output);
end.
- 20.03.2017 08:02
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.