Вопрос по информатике:
Составьте программу нахождения наибольшего общего делителя для двух чисел. (Воспользоваться алгоритмом Евклида). Алгоритм Евклида поиска наибольшего общего делителя двух чисел: вычитай из большего меньшее, пока числа не станут равны. Полученное значение и будет искомым.
- 25.03.2018 10:02
- Информатика
- remove_red_eye 12990
- thumb_up 10
Ответы и объяснения 1
Var a, b: word;
function NOD(x, y: integer):integer;
begin
repeat
if abs(x) > abs(y) then
x := x mod y
else
y := y mod x;
until (x = 0) or (y = 0);
NOD := abs(x + y);
end;
begin
write('a=');read(a);
write('b=');readln(b);
writeln('NOD(a,b)=', NOD(a, b));
end.
- 26.03.2018 03:01
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.