Вопрос по информатике:
Составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и:
1) находит индексы чётных элементов
2) подсчитывает количество отрицательных элементов
- 25.01.2018 23:33
- Информатика
- remove_red_eye 11253
- thumb_up 40
Ответы и объяснения 2
#include
#include
#include
using namespace std;
int main()
{
int chet=0;
mas[16];
int i;
srand(time(NULL));
for(i=0; i<16; i++)
mas[i]=rand()%41+(-20);
for(i=0; i<16; i++)
{
if(mas[i]%2==0)
{
cout << i+1 <<' ';
}
if(mas[i]<0)
chet++;
}
cout << '\n' << chet << '\n';
system("pause>>null");
return 0;
}
- 26.01.2018 19:56
- thumb_up 42
Program r1; var A:array [1..16] of integer i:integerBegin for i:=1 to 16 do A[i]:random(41)-20; for i:= 1 to 16 do if A[i] mod 2 = 0 then writeln(' i,' ');end.
- 27.01.2018 22:17
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.