Вопрос по информатике:
В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.
Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.
входные данные 10 20 выходные данные 9- 12.11.2017 12:28
- Информатика
- remove_red_eye 1380
- thumb_up 30
Ответы и объяснения 1
var
y,n:integer;
x:real;
begin
n:=1;
write('x= ');
readln(x);
write('y= ');
readln(y);
while x < y do begin
inc(n);
x:=x*1.1;
end;
writeln(n);
end.
- 13.11.2017 17:18
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.