Вопрос по информатике:
Дан год. Вывести на экран на экран название животного, символизирующего этот год по восточному календарю (cock, dog, pig, rat, bull, tiger, rabbit, dragon, snake, horse, sheep, monkey).
Формат входных данных:
Входной файл содержит натуральное число
Формат выходных данных:
В выходной файл выведите ответ на поставленную задачу.
- 07.07.2018 23:14
- Информатика
- remove_red_eye 15326
- thumb_up 45
Ответы и объяснения 1
Var
x,y:integer;
a:array [1..12] of string;
begin
a[1]:=cock;
..
a[12]:=monkey;
read(x);
y:=(abs(2016-x) )mod 12;
write(a[y]);
end.
Вроде должно работать. Проверить не могу - сижу с телефона
- 08.07.2018 03:36
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.