Вопрос по информатике:
Составьте программу,которая заполняет массив a[1..10] случайными числами в диапазоне от 0 до 10,затем первый элемент меняет местами с максимальным элементом.Выведите на экран исходный и полученный массивы.
- 04.11.2017 01:17
- Информатика
- remove_red_eye 12775
- thumb_up 19
Ответы и объяснения 1
Uses crt;
const n=10;
var a:array[1..n] of integer;
i,max,k:integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(10);
write(a[i],' ');
end;
writeln;
max:=-1;
for i:=1 to n do
if a[i]>max then begin max:=a[i]; k:=i; end;
a[1]:=a[1]+a[k];
a[k]:=a[1]-a[k];
a[1]:=a[1]-a[k];
for i:=1 to n do
write(a[i],' ');
end.
- 05.11.2017 01:12
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.