Вопрос по информатике:
В паскале сформирвать массив из десяти элементов, заполнить его с помощью генератора случайных чисел и сделать так, чтобы в нем поменялись местами 1 и 2, 3 и 4 значение и так далее. Нужно написать программу.
- 09.01.2015 20:36
- Информатика
- remove_red_eye 16914
- thumb_up 44
Ответы и объяснения 1
Program Task;
Var a: Array [1..10] of Integer;
i, tmp: Integer;
Begin
Randomize;
WriteLn('Сформированный массив:');
For i := 1 To 10 Do
Begin
a[i] := Random(10);
Write(a[i], ' ');
End;
WriteLn;
For i := 1 To 5 Do
Begin
tmp := a[i * 2];
a[i * 2] := a[i * 2 - 1];
a[i * 2 - 1] := tmp;
End;
WriteLn('Измененный массив:');
For i := 1 To 10 Do
Write(a[i], ' ');
ReadLn;
End.
- 01.01.1970 00:00
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.