Вопрос по информатике:
PascalABC, Составьте программу, которая введенное с клавиатуры слово выводит в конце строки, а затем по буквам, начиная с первой, переставляет в начало строки.
- 11.08.2018 17:47
- Информатика
- remove_red_eye 10075
- thumb_up 7
Ответы и объяснения 1
)напиши куда слово встовлять(вначало, вконец, посередине...);
program z2;
var s,s1:string;
a:integer;
begin
write('Введите слово: ');read(s1);
write('Введите строку: ');read(s);
s:=s+' ';
a:=length(s);
writeln(a);
insert(s1,s,a+1);
writeln('Преобразованная строка: ',s);
end.
2)
program z1;
var s:string;
i,kol:integer;
begin
writeln('Введите строку');
read(s);
kol:=0;
for i:=1 to length(s) do
if (s' ')and(s'1')and(s'2')and(s'3')and
(s'4')and(s'5')and(s'6')and(s'7')and
(s'8')and(s'9')and(s'0') then inc(kol);
writeln(Kol);
end.
- 12.08.2018 06:05
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.