Вопрос по информатике:
В театре работает n актеров. Известно, что среди них a – высоких, b – голубоглазых и с – блондинов. Для главной роли в новом спектакле режиссеру требуется только один высокий голубоглазый блондин. Чтобы спланировать свое время для беседы с каждым таким артистом из труппы театра, режиссеру необходимо узнать, какое максимальное или какое минимальное количество артистов из работающих в театре подходит для этой роли.
Требуется написать программу, которая по заданным числам n, a, b и с определяет минимальное или максимальное количество актеров, с которыми режиссер должен переговорить.
- 03.02.2018 04:12
- Информатика
- remove_red_eye 8121
- thumb_up 40
Ответы и объяснения 1
var
a,b,c,n: integer;
begin
writeln('Сколько всего актеров в театре?');
readln(n);
writeln('Сколько есть высоких среди актеров?');
readln(a);
writeln('Сколько есть голубоглазых среди актеров?');
readln(b);
writeln('Сколько есть актеров блондинов?');
readln(c);
if a < b then
if a < c then writeln('Максимальное количество высоких голубоглазых блондинов: ',a)
else writeln('Максимальное количество высоких голубоглазых блондинов: ',c)
else if b < c then writeln('Максимальное количество высоких голубоглазых блондинов: ',b)
else writeln('Максимальное количество высоких голубоглазых блондинов: ',c);
end.
- 04.02.2018 05:04
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.