Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА ОЧЕНЬ ОЧЕНЬ НАДО !!!
1.Составьте программу двух обыкновенных дробей (с клавиатуры должны вводиться их числители и знаменатели ).
2.Составьте программу, позволяющую выяснить, есть ли у N два простых делителя.
3.Составьте программу, отыскивающую наименьший общий составной делитель натуральных чисел N и M.
4. Составте программу, вычесления суммы четырехзначных чисел, в десятичной записи которых есть два нуля.
- 06.01.2015 00:47
- Информатика
- remove_red_eye 14908
- thumb_up 8
Ответы и объяснения 1
Вот первая
var
a1, a2, a3, b1, b2, b3, n : integer;
function NOD (a, b : integer) : integer;
begin
if b = 0 then NOD := a
else NOD := NOD (b, a mod b);
end;
begin
write ('Введите первую дробь : '); read (a1, b1);
write ('Введите вторую дробь : '); read (a2, b2);
a3 := a1 * a2;
b3 := b1 * b2;
n := NOD (a3, b3);
a3 := a3 div n;
b3 := b3 div n;
write (a3, '/', b3);
end.
- 07.01.2015 11:33
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.