Вопрос по информатике:
Добрые люди,помогите пожалуйста;)
Заменить цифры от 1 до 10 словами. Например: 1 - "один" и т.д.Помогите составить программу и блок-схему.
- 04.04.2018 10:59
- Информатика
- remove_red_eye 4970
- thumb_up 36
Ответы и объяснения 2
Var
k:integer;
begin
read(k);
if k=1 then write('один');
if k=2 then write('два');
if k=3 then write('три');
if k=4 then write('четыре');
if k=5 then write('пять');
if k=6 then write('шесть');
if k=7 then write('семь');
if k=8 then write('восемь');
if k=9 then write('девять');
if k=10 then write('десять');
end.
- 05.04.2018 05:01
- thumb_up 38
Заменяет в строке
var
s : string;
i, lim : integer;
begin
readln (s);
i := 1;
lim := length (s);
while (i <= lim) do
begin
if s[i] in ['1'..'9'] then
begin
if (s[i] = '1') and (i length (s)) and (s[i+1] ='0') then
begin
write ('ten');
inc (i);
end
else
case s[i] of
'1' : write ('one');
'2' : write ('two');
'3' : write ('three');
'4' : write ('four');
'5' : write ('five');
'6' : write ('six');
'7' : write ('seven');
'8' : write ('eight');
'9' : write ('nine');
end;
end
else write (s[i]);
inc (i);
end;
end.
- 06.04.2018 20:09
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.