Вопрос по информатике:
Составьте программу ,которая позволяет удалить символы t из строки s.Строка s и символ t,который надо удалить,вводятся с клавиатуры
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 16.07.2017 14:13
- Информатика
- remove_red_eye 4489
- thumb_up 10
Ответы и объяснения 1
Тогда вот, все по букве задания
var
s : string;
t : char;
i : integer;
begin
readln (s);
read (t);
i := 1;
while (i <= length (s)) do
begin
if s[i] = t then delete (s, i, 1)
else i := i + 1;
end;
writeln (s);
end.
- 17.07.2017 18:26
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.