Вопрос по информатике:
Составьте программу которая заполняет массив а [1..8] случайными числами в диапазоне от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями
- 16.02.2018 05:34
- Информатика
- remove_red_eye 5379
- thumb_up 41
Ответы и объяснения 1
Var
a : array [1..8] of integer;
i, count, sum : integer;
begin
randomize;
for i := 1 to 8 do
a[i] := random (10) + 1;
count := 0; sum := 0;
for i := 1 to 8 do
if a[i] mod 2 = 0 then count := count + 1
else sum := sum + a[i];
writeln ('count = ', count);
writeln ('sum = ', sum);
end.
- 18.02.2018 00:12
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.