Вопрос по информатике:
1. Дана последовательность из N
(2<=N<=100000) различных чисел. Выписать в возрастающем порядке все целые
числа находящиеся в интервале от минимального до максимального значения
элементов этой последовательности, которые не находятся в данной
последовательности.
Пример:
pos.in
pos.out
5
1 7 10 3
2
4 6 8 9
2. Дано натуральное число К.
Напечатать К-ую цифру последовательности 110100100010000100000….., в которой
выписаны подряд степени числа 10.
Пример:
dec.in
dec.out
4
1
3. Написать программу, которая
переводит десятичное натуральное число N (1<=N<=2147483648) в
шестнадцатеричную систему счисления. Входной файл: tohex.in, выходной:
tohex.out.
Пример:
Tohex.in
Tohex.out
35432
8A68
- 19.06.2018 05:12
- Информатика
- remove_red_eye 1323
- thumb_up 35
Ответы и объяснения 1
2)program 2;
var
k:integer;
tmp:real;
b:string;
c:string;
i:integer;
begin
k:=0; i:=0; tmp:=0;
write('Введите k:');
read(k);
repeat
tmp:=exp(i*ln(10));
str(tmp:0:0, c);
b:=b+c;
i:=i+1;
until length(b) >= k;
c:=copy(b, k, 1);
writeln(b);
writeln('k-я цифра:', c);
readln(k);
end.
- 20.06.2018 00:33
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.