Вопрос по информатике:
Входной замок на двери Лисы Алисы работает следующим образом:если введено натуральное число, которое меньше 100 или больше 999 − на дисплее устройства появляется надпись «FALSE»; если у введенного числа все цифры различные или сумма цифр числа равна 13 − появляется надпись «ENTER» и можно войти; в остальных случаях − появляется надпись «LOCK».
Входные данные
натуральное число N (1≤N≤10000)
Выходные данные
Необходимо вывести надпись, которая должна быть на дисплее
Примеры
Input.txtOutput.txt 2 FALSE 427 ENTER 318 LOCK- 23.06.2018 11:29
- Информатика
- remove_red_eye 13317
- thumb_up 32
Ответы и объяснения 1
Var
n, a, b, c : integer;
begin
read (n);
if (n 999) then writeln ('FALSE')
else
begin
a := n div 100;
b := (n div 10) mod 10;
c := n mod 10;
if ((a b) and (b c) and (a c)) or (a + b + c = 13) then
writeln ('ENTER')
else writeln ('LOCK');
end;
end.
- 24.06.2018 12:21
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.