Вопрос по информатике:
Постфиксное выражение – это числовое выражение, в котором сначала записываются операнды, а затем знак операции. Например: 3 5 + означает 3+5. Особенностью постфиксных выражений является то, что при их записи скобки не нужны. Например, выражение (3+4*2)/3-1 можно записать так: 3 4 2 * + 3 / 1 -. Написать программу вычисления постфиксного выражения, содержащего цифры и знаки арифметических операций. Операнды и операции разделяются пробелами.
- 21.06.2015 00:27
- Информатика
- remove_red_eye 17456
- thumb_up 46
Ответы и объяснения 2
Var
stack : array [1..1000] of double;
op1, op2 : double;
i : integer;
c : char;
begin
i := 0;
while not eoln do
begin
read (c);
if c in ['0'..'9'] then
begin
inc (i);
stack[i] := ord (c) - ord ('0');
end
else if c ' ' then
begin
if i < 2 then
begin
writeln ('Error!'); halt;
end;
op2 := stack[i];
dec (i);
op1 := stack[i];
case c of
'+' : stack[i] := op1 + op2;
'-' : stack[i] := op1 - op2;
'*' : stack[i] := op1 * op2;
'/' : stack[i] := op1 / op2;
end;
end;
end;
if i 1 then
writeln ('Error!')
else
writeln (stack[i]);
end.
- 21.06.2015 18:12
- thumb_up 6
Программа написана на паскале авс. Считывает из файла строку (выражение в постфиксальной форме), после чего спрашивает пользователя счтать значение выражения или нет. Если вводишь "д" (то есть для программы это да), то она просит ввести значения для переменных х и у, которые могут быть задействованы в выражении и считает значение
- 22.06.2015 05:57
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.