Вопрос по информатике:
Помогите, пожалуйста, составить программу в паскале! Дано четырехзначное число заменить в нем наибольшую цифру нулем.
- 01.12.2015 06:13
- Информатика
- remove_red_eye 1193
- thumb_up 9
Ответы и объяснения 1
Var n,d,a,h,o,max:integer;
begin
readln(n);
d:=n div 1000;
h:=(n mod 1000) div 100;
a:= n mod 100 div 10 ;
o:=n mod 10;
If (d>h) and (d>a) and (d>o) then max:=d;
If (h>d) and (h>a) and (h>o) then max:=h;
If (a>d) and (ho) then max:=a;
If (o>d) and (h
If h=max then writeln(d,0,a,o);
If a=max then writeln(d,h,0,o);
If o=max then writeln(d,h,a,0);
end.
- 02.12.2015 12:44
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.