Вопрос по информатике:
Помогите, пожалуйста, составить программу в паскале! Дано четырехзначное число заменить в нем наибольшую цифру нулем.
- 04.02.2015 07:23
- Информатика
- remove_red_eye 8667
- thumb_up 30
Ответы и объяснения 1
Var
a, i : integer;
c : array [1..4] of integer;
begin
read (a);
for i := 1 to 4 do
begin
c[4 - i + 1] := a mod 10;
a := a div 10;
end;
a := 1;
for i := 2 to 4 do
if c[i] > c[a] then a := i;
c[a] := 0;
if a = 1 then a := 2 else a := 1;
for i := a to 4 do write (c[i]);
end.
- 05.02.2015 20:47
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.