Вопрос по информатике:
Даны действительные положительные числа a, b, c, которые задают длины сторон треугольника и угол между ними. Напишите программу (Паскаль), позволяющую найти длину третьей стороны треугольника и два остальных угла.
- 07.06.2018 17:28
- Информатика
- remove_red_eye 1256
- thumb_up 29
Ответы и объяснения 1
Var
a, b, c, aa, ab, ac : real;
function Arcsin (x : real) : real; begin Arcsin := Arctan(x/Sqrt(1-sqr(x))); end;
//магия. в паскале нет функции арксинус или арккосинус, поэтому приходится выражать через арктангенс.
begin
read (a, b, ac);
ac := ac * pi / 180; // перевод в радианы
c := sqrt (sqr (a) + sqr (b) - 2 * a * b * cos (ac));
aa := arcsin (a * sin (ac) / c);
ab := pi - aa - ac;
writeln (a, ' ', b, ' ', c);
writeln (aa * 180 / pi, ' ', ab * 180 / pi, ' ', ac * 180 / pi);
end.
- 08.06.2018 12:08
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.