Вопрос по информатике:
Вам дана строка S.Надо определить, сколько в ней цифр
Формат входных данных
Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.
Гарантируется, что строка не пустая и ее длина не превосходит 100
Формат выходных данных
Выведите ответ к задаче
- 09.07.2018 20:36
- Информатика
- remove_red_eye 3494
- thumb_up 21
Ответы и объяснения 2
Program Task;
Var S: String;
i, nums: Integer;
Begin
WriteLn('Введите строку');
ReadLn(S);
If Length(S) > 100 Then
WriteLn('Ошибка. Завершение работы программы');
For i := 1 To Length(S) Do
If (Ord(S[i]) >= 48) And (Ord(S[i]) <= 57) Then
nums := nums + 1;
WriteLn('Количество цифр в строке: ', nums);
ReadLn;
End.
- 01.01.1970 00:00
- thumb_up 25
Var
s: string;
k, i: integer;
begin
read(s);
for i := 1 to length(s) do
if (s[i] in ['0'..'9']) then
k := K + 1;
writeln(k);
end.
- 01.01.1970 00:00
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.