Вопрос по информатике:
задается целое число N. нужно вывести количество четных делителей числа N.
Формат входных данных
Единственная строка входного файла содержит единственное целое число N(1<=N<=1000)
Формат выходных данных
выведите ответ к задаче
- 07.10.2015 01:33
- Информатика
- remove_red_eye 17246
- thumb_up 20
Ответы и объяснения 1
Var
i, n, k: integer;
begin
read(n);
for i := 1 to n do
if (i mod 2 = 0) and (n mod i = 0) then
k := k + 1;
writeln(k);
end.
- 08.10.2015 20:57
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.