Вопрос по информатике:
Составьте программу вычисления площади кольца по значениям внутреннего и внешнего радиусов, используя подпрограмму вычисления площади круга(два варианта:с процедурой и с функцией)
- 23.04.2018 08:29
- Информатика
- remove_red_eye 18144
- thumb_up 23
Ответы и объяснения 1
Var
r1, r2: real;
procedure pCircleSquare(r: real; var S: real);
begin
s := Pi * sqr(r);
end;
function fCircleSquare(r: real): Real;
begin
fCircleSquare := Pi * sqr(r);
end;
begin
Write('r1, r2 = ');
ReadLn(r1, r2);
writeln('Функция S = ', abs(fCircleSquare(r1) - fCircleSquare(r2)):5:2);
pCircleSquare(r1, r1);
pCircleSquare(r2, r2);
writeln('Процедура S = ', abs(r1 - r2):5:2);
end.
- 24.04.2018 03:36
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.