Вопрос по информатике:
Вы ввели трехзначное число. затем ввели любое число а. составьте программу, определяющую, равна ли сумма цифр числа задоному числу а
помогите срочно!! контруха по инфе
- 26.06.2016 04:58
- Информатика
- remove_red_eye 10736
- thumb_up 34
Ответы и объяснения 1
Var a, b, c, i: integer;
d: string;
begin
readln(a, b);
d := inttostr(a);
for i := 1 to length(d) do
c := c + strtoint(d[i]);
if (b = c) then writeln('Yes') else writeln('No');
end.
- 27.06.2016 15:19
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.