Вопрос по информатике:
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от -10 до 25.
Программа должна:
1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах;
2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.
3)найти минимальное значение и максимальное значение элементов массива.
- 19.09.2015 05:14
- Информатика
- remove_red_eye 10435
- thumb_up 42
Ответы и объяснения 1
Program x;
const n = 20;
var a: array [1..n] of integer;
s,max,min: integer;
begin
Randomize;
for i:=1 to n do
a[i]:= Random(35) - 15;
for i:=1 to n do
if i mod 2 = 0 then
write(a[i]);
writeln;
for i:=1 to n do
if i mod 2 0 then
write(a[i]);
writeln; s:=0;
for i:= 1 to n do
if (a[i] mod 3 = 0) or (a[i] mod 5 = 0) then
s:= s+a[i];
writeln(s); max:= -15; min:= 20;
for i:=1 to n do
begin
if a[i] > max then max:= a[i];
if a[i] < min then min:= a[i];
end;
writeln(max, min);
end.
- 20.09.2015 22:18
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.