Вопрос по информатике:
Написать программу в Delphi 7, содержащую цикл для вычисления функции
если n=10, A0=0.75, A1=1.6, A2=A3=...=A10=2.0; X изменяется с шагом h=0.2 от X1=0 дo X2=2.0.
- 18.10.2017 02:47
- Информатика
- remove_red_eye 11980
- thumb_up 41
Ответы и объяснения 1
Const
a: array[1..11] of real = (0.75, 1.6, 2, 2, 2, 2, 2, 2, 2, 2, 2);
var
x, h, x1, x2: real;
function F(x: real): real;
var
i: integer;
x_n, res : real;
begin
res := a[1];
x_n := 1;
for i := 1 to 10 do
begin
x_n := x_n * x;
res := res + a[i + 1] * x_n;
end;
F := res;
end;
begin
x1 := 0; x2 := 2;
h := 0.2;
x := x1;
repeat
writeln('x = ', x:3:1, ' y = ', F(x):9:3);
x := x + h;
until x > x2;
end.
- 19.10.2017 03:42
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.