Вопрос по информатике:
1) С клавиатуры вводят слово и символ. Составьте программу, которая: а) определяет позицию заданного символа б) подсчитывает количество вхождений заданного символа.
- 05.05.2018 12:19
- Информатика
- remove_red_eye 18767
- thumb_up 44
Ответы и объяснения 1
Program Zadacha;
Var s: String;
c: Char;
i, pos, count:
Integer;
Begin
WriteLn('Введите слово:');
ReadLn(s);
WriteLn('Введите символ:');
ReadLn(c);
pos := 0;
count := 0;
For i := 1 To Length(s) Do
If s[i] = c Then
Begin
count := count + 1;
If pos = 0 Then
pos := i;
End;
WriteLn('Позиция символа в строке: ', pos);
WriteLn('Количество вхождений символа в строку: ', count);
ReadLn;
End.
- 06.05.2018 12:24
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.