Вопрос по информатике:
В массиве из 10 целых чисел подсчитать сумму
элементов, стоящих правее минимального.Написать программу на языке Паскаль.Помогите, пожалуйста.
- 19.09.2018 23:34
- Информатика
- remove_red_eye 7713
- thumb_up 44
Ответы и объяснения 1
Var a: array [1..10] of Integer;
i, min, sum: integer;
begin
for i := 1 to 10 do
begin
a[i] := random(50);
writeln('[', i, '] => ', a[i]);
end;
min := a[1];
for i := 2 to 10 do
if (min > a[i]) then min := a[i];
i := 1;
while ((i <= 10) and (a[i] min)) do
begin
sum := sum + a[i];
inc(i);
end;
writeln(sum);
end.
- 20.09.2018 14:52
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.