Вопрос по информатике:
дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. СРОЧНО QBaSIC
- 01.09.2017 21:18
- Информатика
- remove_red_eye 14460
- thumb_up 38
Ответы и объяснения 1
Искренне надеюсь, что Вы сможете перевести этот код к нужному виду..:) В принципе, расхождения должны быть только в вводе/выводе (где Console.Бла-бла-бла) и генерации случайных чисел)
Sub Main()
Dim a(29), Sum, Col As Integer
Dim Rnd = New Random()
For i As Integer = 0 To 29
a(i) = Rnd.Next(-100, 100)
Console.Write("{0} => {1}" + Environment.NewLine, i, a(i))
If (i > 0) Then
If (a(i) Mod a(0)) Then
Sum = Sum + a(i)
Col = Col + 1
End If
End If
Next
Console.WriteLine(Math.Round(Sum / Col, 2))
Console.ReadKey()
End Sub
- 02.09.2017 05:47
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.