Вопрос по информатике:
Какой результат исполнения алгоритма
соответствует вводимым значениям переменных: а = 18, b = 26, c
= 10? В ответ запишите число.
- 22.12.2017 02:01
- Информатика
- remove_red_eye 13592
- thumb_up 9
Ответы и объяснения 1
Поскольку алгоритма нет, имею право ввести свой:)
procedure swap(var a, b: real);
var t: real;
begin
t := a;
a := b;
b := t;
end;
var a, b, c: real;
begin
readln(a, b, c);
if (a > b) then swap(a, b);
if (b > c) then swap(b, c);
if (a > b) then swap(a, b);
writeln(a, ' ', b, ' ', c);
end.
В ответе будет
а = 10
b = 18
с = 26 =)
- 23.12.2017 14:21
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.