Вопрос по информатике:
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами.Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива. Все числа по модулю не превосходят 10000
Формат выходных данныхВыведите все элементы массива с четными индексами (то есть A[0], A[2], A[4], ...).
- 08.08.2015 16:17
- Информатика
- remove_red_eye 5067
- thumb_up 25
Ответы и объяснения 1
Вот массив который сам заполняется
uses crt;
const
n=100;
var
i,a:integer;
mas1: array [0..n] of integer;
begin
for i:=0 to n do
begin
a:=random(10000);
mas1[i]:=a;
end;
for i:=0 to n do
begin
if i mod 2=0 then
write('A[',i,']=',mas1[i],' ');
end;
end.
вот заполняемый вручную(чтобы записывать через пробел сам измени)))
uses crt;
const
n=100;
var
i,a:integer;
mas1: array [0..n] of integer;
label 1;
begin
for i:=0 to n do
begin
1:read(a);
if a<=10000 then
mas1[i]:=a
else
begin
writeln('a bolwe 10000');
goto 1
end;
end;
for i:=0 to n do
begin
if i mod 2=0 then
write('A[',i,']=',mas1[i],' ');
end;
end.
- 09.08.2015 17:28
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.