Вопрос по информатике:
В торговом центре этажи нумеруются так: …, –3, –2, –1, 1, 2, 3, … (то есть нет нулевогоэтажа). Вася спустился на лифте с этажа с номером A на B этажей, а затем поднялся на лифтена C этажей. Определите, на каком этаже он оказался.Программа получает на вход три целых числа: в первой строке записано число A, вовторой — B, в третьей — С. Число A не равно нулю и не превосходит по модулю 100, числа Bи С — положительные и не превосходят 100. Программа должна вывести одно целое число — номер этажа, на котором оказался Вася
- 09.04.2018 01:18
- Информатика
- remove_red_eye 14831
- thumb_up 41
Ответы и объяснения 2
Var a,b,c:integer;
Begin
read(a,b,c);
if (a abs(b)) then a:= a - b
else a:=a-b-1;
writeln(a);
if (a > 0) or (abs(a) > abs(c)) then a:= a + c
else a:=a+c+1;
writeln(a);
End.
- 01.01.1970 00:00
- thumb_up 19
Var a,b,c:integer;
Begin
read(a,b,c);
if (a*(a-b) > 0) then a:= a - b
else a:=a-b-1;
writeln(a);
if (a*(a+c) > 0) then a:= a + c
else a:=a+c+1;
writeln(a);
End.
- 01.01.1970 00:00
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.