Вопрос по информатике:
1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2.
2. Найти сумму двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.
- 04.08.2017 21:50
- Информатика
- remove_red_eye 8798
- thumb_up 35
Ответы и объяснения 1
1) var a,b,x:integer;
begin
write('A: ');
readln(a);
write('B: ');
readln(b);
for x:=a to b do
begin
if (x>=10) and (x<=99) then
if x mod 6 = 2 then
write(x,' ');
end;
end.
2) var a,b,x,s :integer;
begin
write('A: ');
readln(a);
write('B: ');
readln(b);
for x:=a to b do
if (x=21) or (x=42) or (x=63) or (x=84) then s:=s+x;
write(s);
end.
- 05.08.2017 23:48
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.