Вопрос по информатике:
В паскале!!!
Известно,
что Покупатель приобрел а кг яблок по цене в руб. и с кг груш по цене d руб.
Покупатель имеет S рублей. Напишите программу, которая определяет, хватит ли у
покупателя средств на данную покупку?
- 07.05.2018 15:23
- Информатика
- remove_red_eye 754
- thumb_up 11
Ответы и объяснения 2
Program cena;
uses crt;
var
s,a,b,c,d,su:real;
begin
clrscr;
writeln('Cymma kotopaya ectb y pokypatelya: ');
read(s);
writeln('Ckolko priobel yablock (kg): ');
read(a);
writeln('Cena yablock:');
read(b);
writeln('Ckolko priobrel grush(kg): ');
read(c);
writeln('Cena grush: ');
read(d);
su:=(a*b)+(c*d);
if s >= su then writeln('dannoy summu hvatit dlya etoy pokypki, vsego za pokupku ',su)
else
writeln('Etoy symmu ne hvatit dlya pokupki');
end.
- 08.05.2018 06:49
- thumb_up 28
Program one;
var s,a,b,c,d,m:real;
begin
writeln('Введите цену яблок , груш ');
readln(s,a);
writeln('Введите кол-во яблок , груш в кг ');
readln(b,c);
m:=(a*b)+(c*d);
if s >= m then writeln('Денег хватит',m)
else
writeln('Денег не хватит');
end.
- 09.05.2018 08:39
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.