Вопрос по информатике:
Решите в Паскаль ABC
Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас
имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в
N рублей так, чтобы она состояла из минимального
количества монет.
- 11.02.2018 22:44
- Информатика
- remove_red_eye 1987
- thumb_up 96
Ответы и объяснения 1
Var a: integer;
begin
readln(a);
writeln(a div 10, 'x10, ', a mod 10 div 5, 'x5, ', a mod 10 mod 5 div 2, 'x2, ', a mod 50 mod 5 mod 2 div 1, 'x1');
end.
- 12.02.2018 21:06
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.