Вопрос по информатике:
Товар стоит a руб. b коп. За него заплатили c руб. d коп. Сколько сдачи требуется получить? Вводятся 4 числа: a, b, c и d. Необходимо вывести 2 числа: e и f, число рублей и копеек, соответственно.
Примеры Входные данные Выходные данные
2
1
3
21 12
1
4
01 99Эту задачу можно решать и при помощи одних арифметических операций, не используя инструкцию if.
- 07.09.2016 11:43
- Информатика
- remove_red_eye 5547
- thumb_up 36
Ответы и объяснения 1
Var a, b, c, d, e, f: integer;
begin
readln(a, b, c, d);
e := a * 100 + b;
f := c * 100 + d;
e := f - e;
f := e mod 100;
e := e div 100;
writeln(e, ' rub. ', f, ' kop.');
end.
Сделал много вычислений, чтобы нагляднее =) Можно даже в 2 строки уложиться, но в данном случае это слишком, наверное:)
- 08.09.2016 15:02
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.