Вопрос по информатике:
1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел
- 20.07.2015 08:56
- Информатика
- remove_red_eye 15327
- thumb_up 47
Ответы и объяснения 1
Var a: array [1..5, 1..5] of integer;
i, m, j: integer;
begin
for i := 1 to 5 do
for j := 1 to 5 do
begin
a[i, j] := random(50) - 25;
writeln('[', i, ',', j, '] => ', a[i, j]);
end;
for i := 1 to 5 do
for j := 1 to 5 do
if (a[i, j] mod 2 = 0) then a[i, j] := 30;
writeln();
for i := 1 to 5 do
for j := 1 to 5 do
writeln('[', i, ',', j, '] => ', a[i, j]);
end.
Для второго не понял, как решать ._.
- 21.07.2015 02:59
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.