Вопрос по информатике:
мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!
- 22.11.2015 09:34
- Информатика
- remove_red_eye 5616
- thumb_up 38
Ответы и объяснения 1
Var a: array [0..10] of integer;
i, m: integer;
begin
m := 1;
for i := 0 to 10 do
begin
a[i] := random(50) - 25;
writeln('[', i, '] => ', a[i]);
end;
for i := 0 to 10 do
if (a[i] mod 2 = 1) then m := m * a[i];
writeln(m);
end.
2)
var a: array [0..10] of integer;
i, m: integer;
begin
for i := 0 to 10 do
begin
a[i] := random(50) - 25;
writeln('[', i, '] => ', a[i]);
end;
for i := 0 to 10 do
if ((a[i] > a[m]) and (a[i] < 0)) then
m := i;
writeln('[', m, '] => ', a[m]);
end.
Можно и меньше циклов, это я для наглядности, чтобы всё не смешивалось =)
- 23.11.2015 07:15
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.