Вопрос по информатике:
Задания на PascalABC. Опишите как можно подробнее ход решения.
№1. Дан одномерный целочисленный массив. Определить количество чисел, кратных 5.
№2. Дан одномерный вещественный массив. Найти сумму положительных элементов, произведение элементов, индексы которых четны.
№3. Составьте программу заполнения массива, не используя клавиатуру, числами: 2, 4, 6, 8, 10, 12, 14, 16, 18, 20.
Заранее благодарю.
- 07.09.2018 08:18
- Информатика
- remove_red_eye 4975
- thumb_up 90
Ответы и объяснения 1
1) Program z1;
var a: array [1..1000] of integer;
n, c, i: integer;
begin
readln(n);
c := 0;
for i := 1 to n do readln(a[i]);
for i := 1 to n do if (a[i] mod 5 = 0) then inc(c);
writeln(c);
readln;
end.
3) var a: array [1..10] of integer;
i: byte;
begin
for i:=1 to 10 do
a [ i ] :=2*i;
begin
for i:=1 to 10 do
write(a[i]:4);
end;
end.
- 07.09.2018 22:06
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.