Вопрос по информатике:
Напишите программу которая вводит натуральное число N и находит все совершенные числа в диапазоне от 1 до N
pascal
- 26.08.2018 15:35
- Информатика
- remove_red_eye 5873
- thumb_up 94
Ответы и объяснения 1
Var i, j, n, p: integer;
begin
readln(n);
for i := 1 to n do
begin
p := 0;
for j := i - 1 downto 1 do
if (i mod j = 0) then p := p + j;
if p = i then writeln(i, '- совершенное число');
end;
end.
- 27.08.2018 00:13
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.