Вопрос по информатике:
Даны натуральные числа m и n.Получить число состоящее из m последних чётных цифр числа n. Написать программу на Паскале только на Паскале.
- 01.03.2018 14:14
- Информатика
- remove_red_eye 9814
- thumb_up 89
Ответы и объяснения 1
Var m, n, i: integer;
a, b: string;
begin
readln(m);
readln(n);
a := inttostr(n);
for i := 1 to length(a) do
if (strtoint(a[i]) mod 2 = 0) then b := b + a[i];
for i := 0 to m - 1 do write(b[length(b) - i]);
end.
Строки - хорошие вещи =)
- 02.03.2018 03:02
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.