Вопрос по информатике:
Turbo Pascal
в прямоугольном треугольнике известны 2 катета, их значения вводятся с клавиатуры.Вычеслить и вывести на экран sin, cos, tg, ctg.
Пожалуйста, помогите составить программу.
- 23.06.2018 18:11
- Информатика
- remove_red_eye 10687
- thumb_up 83
Ответы и объяснения 1
Var a, b, c: real;
begin
readln(a, b);
c := sqrt(sqr(a) + sqr(b));
writeln('sin a = ', b / c);
writeln('cos a = ', a / c);
writeln('tg a = ', b / a);
writeln('ctg a = ', a / b);
writeln();
writeln('sin b = ', a / c);
writeln('cos b = ', b / c);
writeln('tg b = ', a / b);
writeln('ctg b = ', b / a);
end.
Вот так)) Удачи тебе)
- 23.06.2018 23:05
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.