Вопрос по информатике:
Даны натуральные
числа m и n.Получить число состоящее из m последних чётных цифр числа n. Написать программу на Паскале только на Паскале.
- 11.04.2018 03:27
- Информатика
- remove_red_eye 1390
- thumb_up 89
Ответы и объяснения 1
Var i, b, c, n, m: integer;
a: string;
d: array [0..50] of integer;
begin
readln(n, m);
a := inttostr(n);
for i := 1 to length(a) do
if (strtoint(a[i]) mod 2 = 0) then
begin
d[c] := strtoint(a[i]);
c := c + 1;
end;
for i := 0 to m - 1 do
writeln(d[i], ' ');
end.
Так, кажется, только если ввести число больше кол-ва чётный цифр в числе, то будет ошибка, я не знаю, как бороться.
- 12.04.2018 19:05
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.