Вопрос по информатике:
Составить программу обработки данной строки, позволяющую:
a) выписать все прописные буквы из данной строки в порядке их следования;
b) определить, содержатся ли в тексте цифры;
c) найти общее количество круглых, квадратных и фигурных скобок в тексте;
d) выписать все знаки препинания из данной строки, сохранив их последовательность;
- 31.08.2017 22:14
- Информатика
- remove_red_eye 16110
- thumb_up 90
Ответы и объяснения 1
A)
var a: string;
i: integer;
begin
readln(a);
for i := 1 to length(a) do
if (a[i] UpCase(a[i])) then
write(a[i], ' ');
end.
b)
var a: string;
i, p: integer;
q: boolean;
begin
readln(a);
for p := 0 to 9 do
for i := 1 to length(a) do
if (a[i] = inttostr(p)) then
q := true;
writeln(q);
end.
c)
var a: string;
i, p, u: integer;
o: array [0..5] of char;
begin
readln(a);
o[0] := '('; o[1] := ')'; o[2] := '{'; o[3] := '}'; o[4] := '['; o[5] := ']';
for p := 0 to 5 do
for i := 1 to length(a) do
if (a[i] = o[p]) then
u := u + 1;
writeln(u);
end.
d)
var a: string;
i, p: integer;
o: array [0..7] of char;
begin
readln(a);
o[0] := '('; o[1] := ')'; o[2] := '?'; o[3] := '!'; o[4] := '"';o[5] := '.
- 02.09.2017 11:22
- thumb_up 56
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.