Вопрос по информатике:
Введите с клавиатуры целое число в диапазоне 1-999.
а)Определите количество знаков в числе;
б)Определите четность числа;
в)Выведите описание числа,например,"нечетное однозначное число","четное двухзначное число" и тд.
Пример ввода: 347
Пример вывода: Нечетное трехзначное число
- 17.02.2018 08:53
- Информатика
- remove_red_eye 4054
- thumb_up 23
Ответы и объяснения 1
Type num=1..999;
Var x:num; k,y:integer;
Begin
write('x=');
readln(x);
y:=x;
k:=0;
while y0 do
begin
y:=y div 10;
k:=k+1;
end;
if (x mod 2)=0 then
write('Четное ')
else
write('Нечетное ');
if k=1 then write('однозначное ')
else
if k=2 then write ('двухзначное ')
else
write('трехзначное ');
writeln('число');
End.
- 18.02.2018 02:56
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.