Вопрос по информатике:
Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких элементов нет, вывести "NO".
В паскале.
- 21.04.2016 09:56
- Информатика
- remove_red_eye 18074
- thumb_up 6
Ответы и объяснения 1
Const n=15;
var
a: array [1..n] of integer;
i:integer;
p:boolean;
begin
p:=true;
for i:= 1 to n do
begin
write('Введите A[',i,']: ');
readln(a[i]);
end;
i:=1;
while p and (i
if a[i]+a[i+1]>10 then
begin
p:=false;
writeln;
writeln('(A[',i,']=',a[i],') + ((A[',i+1,']=',a[i+1],') > 10');
end;
inc(i);
end;
writeln;
if p then writeln('NO');
end.
- 22.04.2016 04:21
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.